transmission shifting

I have a 2000 focus SE auto... and I have a 'funny' shifting characteristic I was wondering whether it was standard or if perhaps it's forecasting a future problem.
The best example is in traffic. If you're accelerating away from a stop, and the traffic infront of you is suddenly stopping, if the car is close to shifting from 1st to 2nd, and you lift off the gas (because, obviously, you now have to slow down), the ford tranny will feel like it will disengage and 'hang' for just a second or 2 before it'll select a gear.
I noticed on my highway trip this weekend, that maybe 1x each way, the tranny would go to shift on a long uphill, and it'll feel like it's a bit "indescisive" as it's shifting from 4 to 3, for example.
There's no noises or anything, and this may be just how THIS tranny is with the weak little ford engine... but I wanted to touch base with ya'll.
Thanks! Jon snipped-for-privacy@hotmail.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi Jon. My 2000 SE wagon occasionally acts in a fashion similar to what you've described. As a precaution, I had the transmission fluid changed earlier this year (it was due anyway), but there was only a slight change in the shifting performance. I wonder, now, if it isn't a software issue. In any event, the car still performs satisfactorily.
Rob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply Rob,
Do you mind if I ask how many miles you've got on your chariot?? I'm working at about 32k right now.
Jon

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi Jon.
My car just passed 71,000 km.
Rob
--------------------
"Jon Patrick" wrote ...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
USE AMOIL FULL SYNTHETIC!!!!!
FORD OIL SUCKS BIG TIME.
TEST IT. IT BOILS OFF AT 255 DEG. F.
IT SUCKS.
AMSOIL GOES TO 425 DEG F EASY.
J12.
Jon Patrick wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
writes

--
Paul Giverin

British Jet Engine Website http://www.britjet.co.uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yeah, he's flogging the stuff. You see this kind of post in various newsgroups over time.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

--
Paul Giverin

British Jet Engine Website http://www.britjet.co.uk
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Caps lock broken? Just another spammer? Who cares?
--
Michael Heiming (X-PGP-Sig > GPG-Key ID: EDD27B94)
mail: echo snipped-for-privacy@urvzvat.qr | perl -pe 'y/a-z/n-za-m/'
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.