95 Suburban Heater-Defroster Problem

Problem :     I have a 95 Suburban, thatís got a life of itís own ! , when itís cold the heat barely trickles from the vents, the defroster also actís the same?
, however , occasionally the heat decides to work ! when it feels like it. I havenít torn apart the dash yet but I almost ready to if the temperature gets above 20 degrees.
        Also some of the display light cluster by the heater work intermittently when the heater does as well.                  Please help before I call Mr. Expensive Wrench ?
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Sounds like a ground problem. The fiberglass heater box has a ground for the blower motor, and probably for the fancy resistor pack. Distrust factory grounds.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks, Tomorrow will be above freezing I'll check it out.
One small question, Where might the ground be located among all those wires ?
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The blower motor requires a ground. The ground will go from the blower motor to either a ground strap or the wiring harness itself.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.