Electrical issues with 97 Astro

I have an electrical problem with our 97 Astro. We currently have no gauges, gear position display or signal lights. The four way flashers work if the engine
is off but no when its running. When the four ways are going the oil pressure guage fluctuates at the same time.
I can fix it temporarily sometimes by just wiggling wires but it usually doesn't last long.
Just a couple of other other notes:
All the fuses are OK; they've been removed, inspected and reinstalled. The only options are air, tilt and cruise and it still has the factory tape deck.
Any suggestions and/or help would be greatly appreciated.
Thanks
Ian C
--
Ian C
------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Ian C" wrote: Re: Electrical issues with 97 Astro
No gauge, gear position display or signal lights. Four way flashers work when engine is off but not when its running. When four ways are going the oil pressure guage fluctuates at the same time. I can fix it temporarily wiggling wires but it usually doesn't last long. All the fuses are OK. ________________________________________________
All of these symptoms can be caused by a bad ground connection. Examine the main electrical cable connector to the instrument panel and clean up any corrosion in the ground pin and socket. Disconnect and reconnect the connector repeatedly to scrape off corrosion. Clean the terminals and tighten the screws on any grounding wires fastened to the metal structure.
Good luck.
Wendy & John. _______________________________________________
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the reply Wendy & John. I think I've narrowed down the location of the wayward wire &/or connection. It appears to be on the back of the block that has the buzzer and flasher plugged into it, the that the fuse box mounts to. Can anyone tell me what's involved in removing the offending block?
Thanks again
Ian C Calgary
--
Ian C
------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.