Shaking engine

Hi, I have a 1990 olds ciera, the engine is shaking like its missing. The coil pack has been completely changed so has the plugs and wires, does anyone
have any sugestions?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Make sure the wires go to the proper plugs, vague info here, did it do it before, is this is miss, any vacuum hoses or pcv popped off, what engine?

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

As Shep said, be sure your ignition system is working correctly first. Have you also changed the ignition control module? (I think this model has one)
If ignition is okay, you can start looking at the condition of the valves, the condition of the fuel injectors, etc.
There are so many things that can cause this.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It has missed since it was bought 2 wks ago, plug wires are on right,its a 3300 eng. I ll have someone check the pcv valve and vacuum hoses. ty
snipped-for-privacy@nospam.nix wrote:

--
Message posted via http://www.carkb.com

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@nospam.nix wrote:

has even been scanned and isnt showing anything. TY I really appreciate your help.
--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/gmc/200607/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.