Cause of range underreporting by 50% on '04 Accord Nav sys trip computer?

Can anyone suggest a likely cause for the sudden under-reporting by 50% of available range remaining on a full tank of gas with my '04 Accord EX V6 w/ nav system's trip computer? I have reset the "history"
function both on filling the tank as well as repeatedly every 10 miles thereafter while on the highway cruising at 32+ displayed average, not instant, mpg, yet rather than showing a range of ~540 miles (17 gal x 32 avg. mpg) as it used to until 2 weeks ago, the trip computer display has under the same circumstances taken to showing a range left on a full tank of only 226 miles, effectively ignoring half of the fuel in the tank at the reported avg. 32 mpg that is being achieved consistently on the highway.
The range very slowly climbs to 250 miles as the tank reaches displayed 1/2 full, so the problem effectively goes away at a half-tankful but then returns to under-reporting as further fuel is consumed, on the order of a 50 mile deficit, compared to calculations of the amount of fuel remaining based on the displayed avg. mpg for the trip, times the same avg. mpg value.
Could this be a fuel float / sender problem in the tank, or is it more likely the nav. system chip(s)? As the car is now out of warranty, I don't want to spend more than $50 getting this fixed if at all possible. Suggestions, anyone?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If the (Honda?) Nav computer is functioning, it unlikely to be a chip problem. More likely a connector problem somewhere.
If this is a 04 model, how is this out warranty? Does the nav system only have a 12 month warranty?
Stewart DIBBS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Probably the same type of reporting as my gas mileage on my 04 Civic hybrid - reported 48 I get 33
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
This just happened to me this week! Did you get your computer fixed?
--
mike120877
------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Mine is regularly about 0.2-0.3 MPG less then the manual calculation.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.