560SL smoking

My 86 560SL with 133k miles emits a good sized puff of exhaust smoke after sitting at idle for a few minutes when accelerating. Would this be valve stem seals? Is there way to tell?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Bill Bunn wrote:

yes, that would certainly be valve stem seals... unsightly problem, inexpensive fix
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep... valve stem seal.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

One HOPES it's the valve stem seals, which can be replaced VERY CAREFULLY in situ, but it seldom is, it's usually the guides which means the heads have to come off. Renewing the seals usually gives you a few months relief at best.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What color is the smoke? Blue is oil, black is fuel, white is coolant.
Dollars to donuts it's valve guides. A compression test followed by a leakdown test would tell you pretty much for sure.
--
Need Mercedes parts? http://parts.mbz.org
Richard Sexton | Mercedes stuff: http://mbz.org
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.