A160 Problems..Can anybody please help !!

Hi
I would appreciate any help / advice on the following :-
1) Over the last month or so My CD / Radio has started switching..So if Im playing a CD suddenly the radio comes on instead. This has been
happening 1 or 2 times a week. 2) Over the same period my alarm has started to activate approx 30 seconds after starting the car. This has happened 3 times in the last month. 3) However today when driving home the car when stopped (at traffic lights) or going very slow 5 mph etc is starting to chugg along quite badly. It almost feels as if the car is about to stall although it never actually stalled.
Could this all be linked to some sort of electrical problem etc
regards
Hen
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Older M-B models have an "over voltage protection relay" that causes similar strange symptoms when it fails. Don't know about A160s but worth asking about at dealer or repair shop.
--
2006 T.G.Lambach. Publication in any form requires prior written
permission.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.