C220 engine dies sporadically when having to idle

I drive a C220 1993 model and generally love the car. Recently it started cutting out when having to idle (for example when standing at a stop street
or even when at speed and just engaging the clutch with foot off the accelerator) but does not consistently die every time. This happens through all temperature ranges (from start-up to fully warmed up). The engine immediately starts again when the ignition is turned.
My local MB dealer is of the opinion that I need to replace the wiring harness but at the price of >ZAR8500! I'm hoping for some other cheaper solution?? Any advise will be appreciated
Thanks CL
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Buy the wire elsewhere... even out of country and put it on yourself?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the obvious advice! I was really hoping that it could be something else and NOT the harness? Any ideas?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just inspect it yourself... it is not all that hard to determine if wire is bad or not.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.