cam sensor

Help. I have a 1994 e320 I am getting error messages 22,and 25. Cam sensor and crank sensor. I have canges them BOTH and I still set the message.
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do you have a problem of car shutting off on you randomly? I asked because my friend has a 93 E320 and did the same darn thing... he replaced the cam and crank sensor only to find it still shutting off on him.
The result was the overload relay... changed it and the problem is gone.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I already tried that. thanks anyway Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Then there is the last possibility.. the main wiring harness... pull out both carpet by the driver side footwell... you will see a wiring harness go out by the accelerator... and on the opposite side... Inspect these wires and make sure there is no frayed wire.
There was a recall on this matter... the dealer solution was to install a clip to prevent this from happening... I don't know if this is still covered under recall if the wires are frayed.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have you Cleared the code memory?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@aol.com (AJDalton7) wrote in message

yes
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.