Damp Starting Problem

Hi Guru's,
My son has a 2002 SLK230 which starts fine in cold weather and in hot weather but not in damp weather.
The way he describes the problem is: "sometimes it will start but run real
rough, you know, like the wrong cylinder is firing at the wrong time or all the cylinders are not firing. If I turn the key off and then restart it, it will start and run fine."
In my humble opinion, as a mechanic back in the '50s when things were simple, this reeks of something cracked in the ignition-related electrical system. He has replaced the coils.
Anybody have any ideas?
Thanks in advance for any insight.
John Simpson '90 420SEL
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I would check with OBD2 scanner from Autozone (free use) to see if there is any code. It could be the MAF.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Spark plug wires?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Your problem is your mass air flow sensor, I just had the same problem in an 01' After changing the plugs and fuel pump ,and filter the problem was still there obd2 just read misfires,changed maf andit runs like i never imagened.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.