Heated Seat Back not working, 98 C280 Sport:

Hi Everyone:
I recently purchased a 1998 C280 Sport, with heated leather seats. (from what I have read, these are made by Recaro, and also used in the C36 and
some other models).
The bottom section of the driver's seat heats correctly, but the back part does not heat up. Considering the moderate climate we live in, this isn't a big enough deal for me to want to go to the expense of paying a MB dealership to replace the seat, which in all other respects is same as new. However, it would be nice if I could fix it myself somehow.
Are there any other people who have had problems of this nature? Perhaps a tip on looking for a short somewhere in that spaghetti tangle of wires underneath the seat, a cable to replace, a way to replace the heating coil, or something similar?
Thanks in advance for any help!
Art
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It is more likely a broken circuit than a short... if it is a short, you fuse would blow every time. It is not that hard of a job to diagnose... using a ohm meter, just measure the resistance... if you got some low readings, then you know that circuit is fine... if you got high reading or zero reading, then you know the wire is broken in the element and would require a replacement.
Changing it out is not that hard ot a job... just need alot of time. I suggest you just buy a replacement aftermarket one and put it in. unless you want to pay high price from dealer.
http://www.bergwerks.com/seat_heat.jsp
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.