91' S-10 Blazer question

Hello all,
I started my S-10 Blazer 4x4 for a minute to turm my front wheels to plug a hole in my tire then I shut it off. I go to start it again ten
minutes later and I get nothing from the starter. All my lights and stereo ect are working fine along with the buzzer that goes on when the keys are in the ignition. I check my battery cable and the positive side had all kinds of crud on it. I cleaned it and still no go. I barely get a click out of the starter. How do I go about trouble shooting this? Should I just replace my cables? My positive cable looks pretty bad. Also, I tried jumping it using the top post mounts on the battery (Which is not very old)and I still had no luck getting it started. Any suggestions would be greatly appreciated.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.