Windshield problems

I have a '98 DeVille with 86,000 miles on it and my windshield is fogging up. It goes away when I get on the highway. The defrost doesn't seem to be working. Any suggestions as to what is wrong?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Moisture is getting into your heat/vent box somehow. The most common reason is a leaking heater core or one of the hoses going to the core. Check the hoses at the firewall first.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thank you for this info. I just $800 at the dealer to have the water pump replaced and it stopped fogging up the windshield for about a month. I will have the hoses checked out. Are you a mechanic, and if so, where do you live?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Other likely culprits:
1) Plugged drain hose on the A/C evaporator. 2) Inoperative A/C or not directing air to the windshield in defrost mode.
If the moisture is on the inside of the windshield BEFORE you start the car, you may have another source of moisture inside the car (like wet carpets. See #1 above.)
If the moisture is on the OUTSIDE of the window, that's just mother nature and the defroster won't help remove that until the engine warms up.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.