84 S-10 Blazer Instruments Gone Crazy.....

whenever I turn on the headlights, all the gauges, especially the oil gauge, start fluttering like crazy. The previous owner drove it like
this for 100K miles or so, but I would like to fix the problem. Any suggestions? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@peoplepc.com wrote:

start by tightening every ground wire you can find under the dash, and under the hood. They are the black wires. Over the years they tend to loosen up, and can cause all manner of odd problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Good place to start, also make sure none are broke, or coroded, if any coroded, get down to shiny metal and re-install the ground
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On my 85 several of the connections behind the panel were loose.But mine had just stopped working though.Your`s makes me think of a loose ground somewhere like Reed said.Also pull the plug for the head lights and check the ground,If I remember right its the top one,just check all 3 to be sure.
-- -------------------------------------------------------------- When Religion ruled the world , they called it the dark ages...
Don Farr Roswell NM 88203 D-farr AT cableone DOT net --------------------------------------------------------------
wrote:<BR>&gt; &gt; whenever I turn on the headlights, all the gauges, especially the oil<BR>&gt; &gt; gauge, start fluttering like crazy.&nbsp; The previous owner drove it like<BR>&gt; &gt; this for 100K miles or so, but I would like to fix the problem.&nbsp; Any<BR>&gt; &gt; suggestions?&nbsp; Thanks.<BR>&gt; &gt;<BR>&gt;<BR>&gt; start by tightening every ground wire you can find under the dash, and<BR>&gt; under the hood. They are the black wires. Over the years they tend to<BR>&gt; loosen up, and can cause all manner of odd problems.<BR><BR></BLOCKQUOTE></BODY></HTML>
------=
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.