Acceleration problem-1989 Chevy 350

Truck is a 1989 ton with 350 engine. Truck starts fine. Runs good if I accelerate slowly. If I push the pedal down too fast, the engine bogs down.
If I let up on pedal, it will smooth out and run fine again. I changed plugs, rotor, and cap. Any suggestions are appreciated. Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Chief McGee wrote:

fuel filter would be my next choice. (a very- often -forgotten- item that is cheap too) If it is a jerky kind of miss, plug wires.....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Chief McGee wrote:

Catalytic converter.. I had an 89 Celebrity that did the same thing. If I feathered the throttle I could get up to about 50. If I just mashed the throttle, the motor would fall on it's face. Sometimes it would stall. It was really strange, I could get up to 30 MPH, and try to accellerate, it would downshift, but would slow down. KenG
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
KENG wrote:

Thats a possibility but he said it runs fine otherwise. A cat plugged that badly (like yours was) and the thing would only go 50 isn't in the "run fine" category. But.....hmmm....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I changed the fuel filter. That fixed it. Thanks for the help. Chief Mcgee

down.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Chief McGee wrote:

Thanks for letting us know what the answer was to the problem. I wish more people would do this.
Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.