94 Labaron clock

The clock / radio in my 94 LaBaron works one day and then after a few days it is blank. It started a few months ago. I doubt that it's a simple loose connection, because the on / off does not occur while driving (rough road, etc). It's more likely to be off when starting after a few days lack of use and then suddenly be working upon starting several days later and work fine until it's parked a few days.
Any suggestions? No big deal, perhaps more curiosity than anything else.
Reply to
clams
Is it just the display, or does the clock no longer keep time, and the radio no longer work?
I would suggest replacing with an aftermarket unit, or find a used OEM unit. I found a perfectly working OEM AM/FM Cassette for my mid-90's minivan at a thrift store for only $2.00.
A repair shop could probably fix it for you, but they will probably want some cash up front to find out what is wrong, and will usually apply it to the repair cost should you decide to let them fix it.
KM
Reply to
KirkM
It could be a bad connection that a bumpy rough road shakes the connection into making a contact. If the radio is turned on, but not playing see if whacking the dash as close to the radio as possible causes it to play.
Reply to
Pete E. Kruzer

Is it just the display, or does the clock no longer keep time, and the radio no longer work?
Clock no longer keeps time & radio / cassette stop working. One day it works fine and after a few days it does not work upon starting. Then after a few days it works again upon starting.
It never starts up while driving or from what I've seen stops while driving. As I mentioned, it's no big deal as I rarely use the radio, but like having the clock.
I would suggest replacing with an aftermarket unit, or find a used OEM unit. I found a perfectly working OEM AM/FM Cassette for my mid-90's minivan at a thrift store for only $2.00.
A repair shop could probably fix it for you, but they will probably want some cash up front to find out what is wrong, and will usually apply it to the repair cost should you decide to let them fix it.
KM
Reply to
clams
I have the same problem on my 91 aclaim. I know the problem is electrical since it happen right after I changed heater core. My interior light is not working also.
I will open the dash to see the wires.
good luck to you
Reply to
ulas c coskun

MotorsForum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.