Speedometer stopped working on 2002 T&C

My battery died and when I got it started with a jump I noticed the speedometer needle went crazy and circled clockwise and now stopped
working. Must have shorted it out I think? All other panel gages and indicators are working so I don't think its a fuse. Anyone know what this will likely run me when I bring it in for repair?
Thanks, Luke
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Luke wrote:

Luke - Hopefully it will work like the LH cars of the same time period when that happens. From the 2nd gen LH car FSM: "A self-test of the cluster can also be initiated by pressing and holding the odometer reset button and switching the ignition from lock to unlock. The cluster will then step through several displays for functional verification."
You have to hold the odo reset button for about 3 seconds - release when the needle dance starts. The synchro-motor speedometer needle will be forced against the zero peg and will flop back into synchronization. Cost: $zero.zero
--
Bill Putney
(To reply by e-mail, replace the last letter of the alphabet in my
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks Bill. That was the trick!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Luke wrote:

You're welcome!
--
Bill Putney
(To reply by e-mail, replace the last letter of the alphabet in my
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.