1997 ford explorer sport starting problem

it will start up....the engine will turn over but nothing the longest it did this was for a week ...I call to have it towed to the dealership, the guy got here and it started right up go figure....they checked it out and found nothing wrong...I hate to get rid of it because I like it and I dont want to pass that problem on to someone. It only has 78,000 miles and still looks new if anyone has had the same problem plese let me know....(THANKS)
Reply to
militaryguy
Just a guess - Have you tried pressing on the accelerator? If the idle air control valve is stuck shut, it will not start unless you press down on the gas.
Reply to
Big Shoe
Have the CRANK SENSOR replaced. It's probably a $300 fix, and its a gamble replacing it without knowing *for sure* that this is the problem. But the dilema you face is that your dealer will not ever be able to diagnose the problem unless it happens exactly to him while its at the shop. Since this is an intermittent problem, the chances are VERY low that the truck will decide not to start when it is at the shop. Meanwhile, you'll be paying the mechanic to look at the truck and tell you there's nothing wrong.
It's a gamble replacing a part that you don't know for sure is broken - but your symptoms are exactly the same as mine and changing it now will save you money in the long run.
Reply to
mrkennyg

MotorsForum website is not affiliated with any of the manufacturers or service providers discussed here. All logos and trade names are the property of their respective owners.