110 Intermitant Clutch Slip

Hi, I'm suffering some clutch slip on my 86 110 CSW but only after its battled along the motorway for 30 mins or so. After a couple of miles
off the motorway it goes away and I can't replicate the fault when the engine is cold. Even with excessive revs when applying the brake the engine starts to stall as it should and everything appears normal. Is this just the first sign of the clutch starting to go, or is there something else that could be causing this?
Thanks
Smudge
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Smudge wrote:

Any oil dribbling out the bellhousing? If so the main crank seal has gone & could be contaminating the plates etc??
Mind you, it would more than likely slip all the time!
Could be lazy clutch fingers etc?
--
Subaru WRX (Annabel)

Landrover 110 County Station Wagon (Tyson)
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yep, oil drinbbling out of housing. Mind you, there seems to be oil dribbling out of everywhere!. How big a job is replacing the crank seal and how do I check that its this thats causing the problem?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.