99 GT Questions

Hey all, I've got two questions about my '99 GT.
        1) When the car is running between 1500-2000 RPM (any gear), it
produces a "whirl" noise. Go under 1500, or over 2000, and it goes away.
        2) Certain times, none predictable, when applying my clutch, it does not feel smooth. However, say 5 minutes later under the same conditions, it does feel smooth. The feeling I'm getting is like a "grainy" feeling.
Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I have had some odd feel to my clutch pedal... I have a steeda quadrant, cable, and firewall adjuster so this might not apply to your car. It would feel like it was binding and made some ugly noises at times. I greased the cable the best I could at both ends. Made it a little better. Then one day it stopped and it's been gone since. Best I can guess is that the grease worked its way to the spot that needed it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Brent P wrote:

Brent,     Thanks for the reply. I'll try that, however, mine doesn't make any noise. Nonetheless, it's worth a shot.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.