1993 Saturn SL1 keeps stalling

My 1993 Saturn SL1 starts up fine when the engine is cold (like in the morning) but stalls during the day after the car has been running and the
engine is hot. And then the car will not start. It turns over but the engine does not seem to be getting gas. The "check engine" light is on. The fuel pressure regulator has been changed but the car still stalls. Any ideas of what could be causing the problem????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

So why is it on? Have you had the diagnostic codes read yet? If so, what are they? If not... why not?

Did anyone actually measure the fuel pressure, or was that just a fishing expedition?

Without knowing the diagnostic codes, all you can do is guess.
--
Regards,
Doug Miller (alphageek at milmac dot com)
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Go to any Autozone and they'll read the stored codes for no charge, or have a proper diagnostic done by your local Saturn dealer. It beats replacing parts based on guesses.
Lane [ lane (at) evilplastic.com ]
--
Visit my Saturn Car Audio and Performance Page at http://www.evilplastic.com


"cubes" < snipped-for-privacy@rc.com> wrote in message
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.