1993 Intrepid random stalling

Hi All, I have a 93 intrepid with the 3.5l engine that randomly cuts out on me. It doesn't fade like if its losing gas. Things I have done to it recently that have not helped
Cleaned the throttle body. Cleaned the TPS Changed the fuel filter Replaced a leaky fuel line changed the cam sensor It still stalls randomly. The only thing in common is that it happens during the day when it is hot out. In the evenings when I get home from work it rarely happens Any ideas? Crank sensor maybe? Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Plug wires?

on
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
They could cause random stalling? NowItsWhatever wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Any codes? How old is the battery.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
No codes and 1 year old battery. I also cleaned and tighened the connections Art wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Eric wrote:

Our 93 3.5 has had two annoying bouts of random stalling. First time was the crank sensor (no codes set). The second time it was a bad connection at the MAP sensor, which finally did set a code.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'm leaning towards the crank sensor I think Steve wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
clean carbon off of throttle body and plate
Eric wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just curious how much it cost you to change your ignition switch? I have a 93 Intrepid 3.3L with a similar problem. A lot of times my car will start and run just fine, however, all my dash gages, idiot lights, tach, spedo, fuel, etc... are all dead. headlights, interior lights, radio, & accessories work just fine. Wonder if I need a new ignition switch? Thanks for any info you may have.
--
nelsd99
------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Crank sensor maybe, failing fuel pump or possibly ignition switch needs replacing..
6-8 months ago along a period of a week or two..my 95 Intrepid 3.3 169000 miles would just die cruising on the hwy..when cruising all dash lights would come on and car would immediately die..most times would restart immediately..
Eric wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Crank sensor maybe, failing fuel pump or possibly ignition switch needs replacing..
6-8 months ago along a period of a week or two..my 95 Intrepid 3.3 169000 miles would just die cruising on the hwy..when cruising all dash lights would come on and car would immediately die..most times would restart immediately..
Had a spare crank and cam sensors..replaced them but didn't solve problem..
Took it into shop and they diagnosed it as a failing fuel pump..Replaced it and still same problems..
I did a google search and saw several posts on flaky ignition switch..
Replace it then; now have 179000 miles and no further problems immediately after replacing switch..
Rich
Eric wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I know my ignition key is worn down quite a bit. That may be something to look at Thanks

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.