cruise control

Hello group,
Again a line from Holland. Does anyone know how to replace the handel for the cruisecontrol/wipers and headlight switch? I've been lookin' in the haynesbibble but can't find it. They told me to
yank it sideways out and detach the cable, and put the new one in. Since all works except for the CC, first it hesitated when i turned on the wipers now it completey died on me. What to do now?
Thanks in advance
Marc
K1500 '88 4X4
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The Handle just pulls out . Pull it straight out.
Why do you think the handle is what is defective?
You can unplug the handle at the base of the column and plug in a new one for a test .
: Hello group, : : Again a line from Holland. Does anyone know how to replace the handel for : the cruisecontrol/wipers and headlight switch? : I've been lookin' in the haynesbibble but can't find it. They told me to : yank it sideways out and detach the cable, and put the new one in. : Since all works except for the CC, first it hesitated when i turned on the : wipers now it completey died on me. : What to do now? : : Thanks in advance : : Marc : : K1500 '88 4X4 : :
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
At first the CC worked well, suddenly it stopped when i turned on the wipers the cc stopped, and couldn't be set again to maintain the preset speed. I had to turn it off and on again and set the speed again, this was later on also when i turned on the signal lights to make a left or right turn. Now it won't work at all, except for everything else. Wipers and turnsignal and hi-beam still works OK. So it must be the handel, probably some wires chafed off in all those years, i guess. Thanx for the possible solutions, i'l check for the right answer. ]Marc

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On my old 1988 C1500, there is also a small relay (looks like the hazard flasher relay) up under the dash to the left of the steering column that controls the cruise control. If I recall correctly, I had to replace it at about 150,000 miles to get the cruise control to work.
If your wipers now don't work, it's either because you tried to remove the stalk and didn't re-seat it properly into the switch inside the steering column, or the switch itself is bad. IIRC, the wiper switch needed to be replaced at about 180,000 miles.
Cheers - Jonathan
--
Acta Non Verba - Deeds Not Words
Lieutenant Jonathan Race, EMS Supervisor
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If you're going to replace this, do yourself a favor by tying a string to the plug on the old one before removing it. After tying the string, wrap a piece of electrical tape tighty around the plug and string so that it forms a smooth and tight seal (to keep it from hanging up when you pull the wires out. After removing the switch, transfer the string to the new one and tape it tightly. Gently tug on the string to feed the wires back down through the column. Remove the tape and string and hook'er up. I've used this method numerous times and it has never failed me.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.