02 A4 ESP Indicator Light

The ESP Indicator Light comes on and stays on when I'm at highway sppeds for an extended period of time. I've taken the matter to Audi but their techs
can't figure the problem out. Anyone else ever see this before?
My car is a 2002 A4 3.0 with 6 spped manual transmission.
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Doug, don't have the same car but sort of similar, it's an '02 1.8T, thought I'd throw it your way anyways. Had an oil/filter change done at a local "quick lube" vs the Audi dealership. After leaving the place, my ESP and Check Engine light came on after a few minutes and stayed on. Car seemed to drive just fine. The lube place swore up and down it wasn't them.
Went to my dealer who, fortunately for me, looked at it on the spot in parking lot. Turns out that they damaged the air intake sensor while replacing the filters, both the engine and cabinet one. I can't begin to re-explain why the ESP and Check light would come on but they said, if I remember right, there's so many interconnected systems/components that it "could" cause this.
They replaced the sensor, which they said is not uncommon and is very sensitive to damage, and the car's run like a dream. Immediately after leaving the dealership, took off from Canada down to Boston, Cape Cod, Martha's and back with no issues and the light's never come back on.
Weird one, but thought I'd throw it out there.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.