Check Engine Light on Road Trips

Hi Everyone,
I've been getting the same problem for a while now. I have a 2002 Audi A4 Quattro 1.8T manual transmission.
When I go on a road trip I usuall pull over after two to three hours for the
first pit stop. (all highway driving for at 120 kph constant) After I am done my stop, after I accelerate out back to the highway the check engine light goes on after a few minutes and will stay on a for a day or two even after the road trip is finished before turning off. This has happened the last 5 out of 6 journeys. I see no changes in fuel economy or the temp guages so I am wondering what kind of sensor problem it might be. I never get the check engine light on shorter trips of normal driving of up to 30 minutes in the city/highway driving. At first I though it was bad gas (which has happenned a couple times it seems) but it happens even when I don't fill up either.
And Ideas what it might be. I don't have a code reader. I will have it checked when I take the car in, but its always night to get some ideas.
Thanks, Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
here are some possibilities or ideas here http://www.bentleypublishers.com/tech/vw/vw.dtc.table.htm

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.