EM Warning Light

I am in Dorset, UK. My car is an Audi A3 1.8SE petrol engine, 4 years old, 24,000 miles only.
About 2 weeks ago, my EM warning light came on and stayed on. The car
was still driving perfectly normally, but I took it to the local franchise dealer, who charged me 100 to diagnose the problem, and change a temperature sender.
The light came on again after a week, car still driving normally, so back I went. They told me it was a sporadic fault, indicating weak mixture. They checked lots of things which proved OK, cleaned some connections, reset the fault indication, and fortunately charged me nothing for doing it.
Today the warning light came on again. The car still drives perfectly normally, but it is going back tomorrow for another check-out. I am beginning to feel pretty pissed.
I would welcome any comments, please.
Has anyone else any similar experiences to mine?
Can sporadic problems ever be fixed?
If the car is driving normally, should I even bother to take the car back to the dealer when this light comes on?
Are there any experts arround other than Audi franchise dealers who might be better able to fix the problem?
Regards, Phil.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Might be worth getting yourself a OBD2 tool then you can diagnose the fault yourself when you go in next time, ask the dealer what the fault code is, someone here may be able to help more, specially if they know the fault code.
I have ordered a obd tool from ebay, so should have it soon. think it was about 60 quid.
Ronny
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I just traded in my 2001 A6 2.7T (for the new A6) I loved the car, but the Check Engine light was on for at least three of the four years I had it. The dealer fixed, and it would come right back on. Design flaw I hope they have fixed for '05. No recall, no dealer knowlege of what the problem might be, once it was turbo parts, mostly they said "miscellaneous fault codes without any specific cause" Hmmm, does not sound plausible. Anyway, performance unaffected.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Mine's on right now - '01 A4 2.7. Stays on for a few days, goes off for a day or two, comes back on. I thought it might correspond with an empty or full gas tank, but I just filled up and it stayed on. I have added injector cleaner and replaced the air filter. Car runs fine and has only 34K miles.
--
Wayne Crannell
Xxxxxxx, TX
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.