330 transmission problem

I have a 5-spd manual. When shifting from 1st to 2nd, as I let the clutch pedal out, the car sometimes "leaps" forward. This only happens between 1st
and 2nd and is intermittent. The dealer has looked at the transmission twice and can't find a problem. Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I think it's unlikely that it's a transmission problem. You don't say what year it is, but 330i only had the 5 speed manual for the '00/'01/'02 model years. The early years of the electronic throttle had a couple of problems - one required a new throttle potentiometer, which was mostly done under warranty. The engine program tries to keep the same rpm, and sometimes glitches - I most often see this (even though I've had the throttle replaced) from start in 1st.
FloydR '01 330xi
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
ps - to Floyd - i hope i didn't offend with the comment on your math booboo
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yeah, I've thought about removing it, but it's not the highest thing on my task list.

Nah; I should have caught it myself.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.