Rear window washer problem (E34 Touring)

I have a 1992 525i Touring.
The rear window washer fluid tank is full, but no fluid is delivered to the window when I push the wiper lever forward. I hear the sound of an
ailing motor, a rather unpleasant grinding noise.
The wiper itself works.
If anyone has any suggestions as to what the problem could be and how to fix it, I would appreciate it.
Thank you.
-- Michael Poplawski Victoria, BC Canada
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

It sounds as if one of three things are wrong:
1) The hose from the pump to the sprayer or the sprayer itself is clogged.
2) The intake for the pump is clogged. (The pump is located inside the washer reservoir.)
3) The pump needs replacing.
That's the order I'd check things. You can insert a needle into the sprayer to remove any debris that may be clogging it.
--
"I have studied many philosophers and many cats. The wisdom of cats is
infinitely superior." - Hippolyte Taine
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Assuming the pump/filter is ok, have a look at the section of pipe where it goes from the body of the car to the tailgate itself (near the right hand hinge). The tube can get damaged in this area and every time you operate the washer, water just squirts out of the split and runs down the edge of the tailgate. Open the tailgate nd get someone to operate the washer. You'll see what I mean. You'll have to remove the small cover plate to repair it.
JB
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.