XM Dip Beams gone AWOL

Despite much muttering on the XM email list about the dip beam, I've never had ANY problems with the headlights, have I?
In the five years I've had the car, I had to replace ONE dip beam bulb -
when I first got it.
So what happens last night?
We're leaving a party at about 1am, I turn the dip on - and they come on, nice and bright, then they go a bit dim, then they go bright again... then the bastard things go OUT.
Oh, bugger.
A quick poke and slap at the relays in front of the air filter doesn't do anything.
So - 20 miles round the motorway (luckily only a little bit either end not on the motorway - and that end was street-lit) with sidelights and front fogs, looking like some chav tosser in a Max-Power Corsa...
WHY do these chavs CHOOSE to drive on side-and-fog? There's NO light gets thrown out...
Hiho. Luckily, the lanes this end had nobody coming, so main beam was fine.
Anyway - time to see what's up.
The handbook suggests a fuse for each dip, so unlikely to be those. Relay? Are they relayed one-per-bulb or one for the whole dip?
Odds on it being that f**king fuse box again... <mutter>
<fx: Disappears outside> <fx: Gets cold and grubby> <fx: Comes back in, cursing> <fx: returns>
A quick poke and slap at the relays in front of the air filter doesn't do anything.
And nor does a proper remove/spray with contact cleaner/swap around/prod/poke...
Actually, that's not true. I dropped one. It disappeared down into the bowels. and I can't find it any more.
There's three 35A relays on the airfilter side, and one 25A by the ECUs. ('96 s2 TCT Auto with climate)
It's one of the three 35A that I dropped.
The 25A took a lot of persuading to remove, but it did come in the end. It's definitely doing *something*, because wiggling it with the ignition and lights on gives some clicking. Nothing seems to go on/off, though...
Both dip fuses have 12v to them with lights/ignition on, so I guess the relay's fine?
Surely both bulbs can't have died simultaneously, can they?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Adrian wrote:

I'm not sure but someone in another group gave a link to this site which does BX and XM faults.
http://www.tramontana.co.hu/citroen /
--
Malc


Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Nope, its the big multiplug that you will find knocking around behind the passengers side lights - take it apart and you will see the bit that has melted during the whole "lights go a bit dim" phase of the failure...
...give it a bit of a wiggle and it'll come back temporarily - the proper fix is to rewire it.
CAS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
CAS ( snipped-for-privacy@yahoo.com) gurgled happily, sounding much like they were saying :

<groan>
Ta.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
CAS ( snipped-for-privacy@yahoo.com) gurgled happily, sounding much like they were saying :

It is with GREAT pleasure that I can report that you're wrong, Calum.. <phew>
It WAS both bloody bulbs.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How weird!!
Now you need to find what caused the voltage surge that popped them both!!! :op
CAS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
CAS ( snipped-for-privacy@yahoo.com) gurgled happily, sounding much like they were saying :

Especially since I've not once had to replace a headlight bulb since I bought the car five years ago...

BUGGER OFF, YOU'RE NOT HELPING AT ALL.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Adrian, you are in denial. You should seek professional help...
...from an auto-electrician!!! LOL!!!
(Sorry)
CAS
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
CAS ( snipped-for-privacy@yahoo.com) gurgled happily, sounding much like they were saying :

When I bought some new relays yesterday from the local auto-sparky, we were chatting - "I don't get many XMs in" quoth he - No, but when he does get one, it's usually mine...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.