Engine shutdown

I have a 95 Vette with 77k on it. I bought it 2 1/2 yrs ago. It had 75k. A couple of months after getting it I was at a stoplight and it stalled. When I restarted it would
only turn over and over. I waited 10 minute's or so and it fired up with no problem. This happened a couple of times. Last week I was on the interstate at 70 miles per hour and I notice the aftermarket CD/Radio was cutting out or skipping. Very soon after hearing that the engine stalled and completely shutdown. Same thing, it would not immediately restart. Waited 10 minutes and again it fired up and I headed home. It did this one more time before I got it home. It has a MSD ignition and it has a 3000 Stall Torque Converter. It also has a after market CD/Radio. Any ideas on what the problem may be. Thanks Ron O'Quinn
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
rigger wrote:

The MSD ignition...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
rigger wrote:

ignition & wherever the installer chose to connect the new radio.
Intermittents are never fun, particularly when they finally fail and leave you in the boondocks.
Regards and best wishes.
-- pj
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.