2000 Cirrus with 2.5l

Speedometer is my Cirrus stopped working while driving; it pegged past 120mph then when back to zero. Odemeter still works and transmission shifts normally. Couple of years ago I had to replace the speed sensor
on the transmission but the symptom was somewhat different; the transmission would not shift out of first and the speedometer did not work. Any ideas?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Possibly the circuit board or gauge?
Glenn Beasley Chrysler Tech
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Maxpower may have a good point. Maybe try and push on the cluster as you are driving. My 96 Neon had a guage - dash problem, after living with it for several years I pulled the circuit board and found cracks at the solder joints where it plugs into the car harnesses. resoldered all the joints on the circuit board and has worked fine ever since....
Stuuder
Car1229 wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Stuuder wrote:

dash to no avail. Taking out the speedo sounds like a good idea the question is how....it does not look easy.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.