96 dodge 1500 hard to start

Well I fixed an overheating problem with a new thermostat!Yaaa! Truck started great int he morning, but as soon as it warmed up it decided it did not want to start or so I thought. If I crank the starter and
hold it, it will eventually fire up. It does bang and ping irradically but then finally catches with a roar of the engine(?) I popped the hood and heard an awful sound while it is idling crazily, it is a load hissing noise that goes away once the engine calms down. There is also black smoke coming out of the tailpipe, however it stops once the engine calms down and starts idling properly. I know this is long, sorry. Any suggestions on what to try? PCV valve already checked
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Run codes, check crank sensor

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually sounds more like a map sensor unhooked, but the systems are so inter-related one must diagnostic check the system to get going.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.