99 durango 2WD won't start

hey guys, im new to this website and i need some help. my durango's battery died on me about six months ago. so i got a new one. but with the gas prices
going up, i had to stop using it for a while. so i haven't touched it for about six weeks. now i tried to start it but the battery lost power. i tried to jumpstart it but it's not doing anything. all i hear is rapid clicking and nothing else. is it the battery?
--
nocupholders

------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Connections clean and tight?
Roy
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yes it's clean and tight, im hoping it's just the battery being dead instead of some more much complicated expensive stuff
--
nocupholders

------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Did you pull your IOD fuse when you parked it? No? charge your battery;

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
sounds like a good idea, i'll bring the battery to pepboys for charging, thanks
--
nocupholders

------------------------------------------------------------------------
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.