Gas Gauge

I have a 93 Dakota, 3.9 auto. Gas guage went a little flaky after a few years, then I needed a fuel pump at some point. Dealer indicated he replaced the sender unit in the tank, and my guage worked better,
but eventually just quit working. I have been going by the milage (odometer) for the past 6 years. Now I'm curious, IF I can assume the sender is not the problem, is there something else I can look at?? I certainly don't want to put any real money into this fix, but I may let my father in law use the truck, and I'd like the guage working. It just lays flat on empty, never moves, and also the little gas pump light is on. I guess a bad connection somewhere, but was hoping somone would have an idea to narrow my search. And I don't want to fiddle with the tank, thats just to involved. But I may be inclined to remove the dash face.
Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If it's the same one in the Ram then the sender is the problem. It's not difficult to fix but you will need to remove the tank in order to effect the repair. The part is available as just the sender from the dealer so don't let them tell you that you have to buy the entire assembly. I think the part was about $40 or so when I did mine in my Ram.
--
------------------------------------------
Laszlo Almasi
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.