'93 TA hiccup.

'93 TA, V8, six speed. 115,000 Mi. I think the catylistic converter element is loose and rattleing around in there. I believe that happed when a spark
plug tip came off at 70,000 miles and I drove it too long and it was dumping raw fuel out that cylinder and overheating the cat. I think there may some exhaust leaks around it too.
My current problem is at idle.
1. Sometimes won't start unless you give it gas. 2. Sometimes won't idle above 500 cold. 3. sometimes the idle will swign from low to high and if you don't inerveen, it will eventually die on the low swign. 4. Sometime the "check engine" light comes on between 20-40 miles after cold start when you are driving down the road. (50-60).
My thoughts:
1. Loose catylicic element is causing wrong signals to engine. (from O2?) 2. Air temp wires got chewed through by rodent and was quickly repair with bad solder joints and electrical tape. May be bad connection.
Any ideas?
Thanks John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

element
dumping
inerveen,
cold
A lose core in a Catalectic Converter means it needs replaced. Being lose it can not only restrict flow, it will eventually stop working.
You should use a High Quality replacement, and have it installed by someone who is good at welding exhaust pipes. Never just clamp on a converter, always weld them in. Charles
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.