2000 Windstar Alarm

I have a 2000 Windstar that I seem to be having a problem with the alarm or something else. Little bit of background. Bought the Windstar new, power everything, incl.
rear sliders, rear ac. No major problem for 2 years. Then alarm starts going off for no reason. Take it in, Ford says the battery has a bad cell. They replace it under warranty. Fast forward to Oct. 2003, same problem. Take it in to Ford, they say nothing is wrong with it. Charge battery at home, ok for 2-3 days, then does it again, but now having a problem with it not wanting to start. Take alternator off and have it tested at an independent shop. Shop says it is bad, go back to Ford with report, they replace it, but covered under extended warranty, costs $50.00. No big deal, it's fixed, right? Not! Last week, it started doing the same thing. Charge battery, lasts for 2-3 days. Check alternator ant shop, checks ok. Ford says it will cost $120 for new battery (that is less than 3 years old!!!). I say it should be covered under warranty, they argue, I go out and buy a battery for $70. Put battery in, everything works fine. Go to bed, wake up with alarm going off (mind you it is now 12:30 am). Started just fine. I locked all the doors, but don't set the alarm and go to bed. What would cause this to happen? Anybody want a guess at this? TIA
Buddah
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.