2003 Explorer Chime problem

Have problem with chime on all the time on 2003 Explorer When door is open with or without key in ignition you hear fast chime.
I was testing different things on my taurus to see when i should hear
chime.
The fast chime seems to be when lights are left on. Slow chime seems to be when keys left in.
So I think the problem with the Explorer is chime for light been on. but the lights are not on. I have turn the light switch on and off trying to jar something so maybe it would stop but so far no good. What else can I check to make sure I find the source of the problem? I know the ignition could be the problem or the door jam. Not sure the light switch would be the problem since lights work.
Thanks for any help I get.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well must be Ignition problem, because today she said when she went to hit the lock doors button on the door it locked for 1 sec and came right back up to unlock. So the car thinks the key is still in ignition and is try to not let you lock your keys in the car, even thought key have been removed.
How had is it to replace Ignition on 2003 Explorer? Or how much would the dealer charge?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There is a small key in ignition switch that is attached to the main lock cylinder. Sounds like it may indeed be stuck. Not a huge deal to replace.
--
Message posted via CarKB.com
http://www.carkb.com/Uwe/Forums.aspx/ford/200608/1
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.