Help? - Passive seatbelt system

The passenger side passive seatbelt doesn't work in my '93 T-bird. I've replaced the motor unit with a tested used one, but it's still dead. There
doesn't seem to be any current getting to it. What else can be the cause? I haven't tested the wires that the motor connects to. Oddly enough, the "fasten belt" dash light still comes on when I disengage the passenger side shoulder strap. Chilton's repair manual is pretty useless for this particular problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"" wrote: > The passenger side passive seatbelt doesn't work in my '93 > T-bird. I've > replaced the motor unit with a tested used one, but it's still > dead. There > doesn't seem to be any current getting to it. > What else can be the cause? I haven't tested the wires that > the motor > connects to. Oddly enough, the "fasten belt" dash light still > comes on when > I disengage the passenger side shoulder strap. Chilton's > repair manual is > pretty useless for this particular problem.
I would check the stop switches on either end of the track
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.