ignition light

Hi,
My Ford Fiesta (1.6 Ghia) has the ignition light ON even when the keys are out of the ignition.When the ignition is on or the engine is running the
light is OFF.
On recommendation I have fitted a new alternator but the problem remains. The light remains lit even when I remove the 'sensor' cable from the alternator.
Ultimately the symptom is that the battery now goes flat if left for a few days. Could the problem simply be a dead battery ? I don't understand why the igition light is lit, unless there is a short in my electrics..
Any suggestions ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Maybe the ingnition-switch is faulty. Just pull the connector from the switch. If the light disappears the switch is faulty. If it stays on there might be a short in the wiring or maybe one of the relais (on the back of the fusebox) is sticking in the on position.
The recommendation to switch the alternator would have only be correct if the ignition-light stayed on when the engine is running.
--
Hennie van Dalen
www.chello.nl/~h.vandalen11
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not quite right,, if the diode pack is defective, the ignition light will stay on with the engine running and also when the engine is off, Peter

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.