2000 focus horn stopped working

I recieved a Focus from my father this week. The horn just stopped working. He said that it happened to him before and he had it fixed, but he doesn't recall what the problem had been. Is this something that could be
fixed easily by oneself? Or should I take it in.
thank you for your time -dimestore
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
You check your fuses?
Mojo

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Yes, sorry, I should have mentioned that. The fuse is fine.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 01 May 2005 14:16:24 GMT, "dimestore"

Now this is me, i'm comfortable working under the hood.
I would rule out a bad connection or horn by hooking up 12volt directly to the horn. If it doesn't sound, horn bad, duh. Horn sounds, wires bad. duh.
If horn is bad, test the wires still, with a test light and someone pushing the horn button.
Then I would work from there. Tell us your results if you think you can safely test this.
later,
tom @ www.WorkAtHomePlans.com
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
dimestore wrote:

but he

could be

My horn stopped working on my 2001 during the warranty period. They replaced the horn.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I had 2 sets of horns replaced under warranty, I guess they're not really reliable in wet conditions... Eventually got an aftermarket horn! :)
Peter
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.