Replacing Focus Battery and ECU

Just rep[l;aced battery, local ford dealer sold me a universal one, not the original, and the flippin battery strap I just bought (so and so's said I had to but belt and bracket and bolt for 11) is too long for the
generic battery (even the shorter white one...)
Is there a precise process to get the ECU to recalibrate
Haynes says Idle till warm 1200 rpm 2 minutes then 5 miles driving
just done that and its running terribly, really lumpy idle, and accelerating, engine warning light starts flashing and then goes out the comes back on again then goes out etc.
Any ideas anyone
Zetec 1.8 2000
(they knocked another 200 off for the incorrect advert...)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Have you knocked the wire off the air mass meter during battery change?
Running should not be anywhere near this poor during learning, and certainly not with a flashing MIL lamp.
Tim..
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 28 Feb 2006 18:47:56 +0000, Tim.. wrote:

yeah, thought it might be something else problem with the car
It was running rough and missing (sort of has power then chokes up then has power then chokes up etc. and missing at low revs) before I changed battery, so it obviously wasnt the battery... thought it might be.
its still doing the same thing after the battery
It starts OK.
I was wondering if it was the last tank full of gas I put in... It started after that...
can the self test mode on odometer show fault codes?
This list looks like it might be different to my ECU which does go into test mode.
http://www.focushacks.com/index.php?modid7
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 28 Feb 2006 18:47:56 +0000, Tim.. wrote:

Checked air mass meter connections and they are OK.
Waiting for a TEKMATE http://www.tekmatetools.com/index.html from http://www.gendan.co.uk
That should shed a bit of light on it...
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.