There it is again!

That smooth ride! Where have you been for so long!!
Recently i started to doubt my 2001 Focus wagon Tddi. Ever Since it was serviced at 105K (just an oil change if i remember well) early this year
it felt a bit lumpy, if you know what i mean.
It felt a bit like the old Sierra's or Escorts did, i was all over the place in corners, it would not drive straight as well, it also made a loud noise in the back, like the wheelbearings had gone almost completely. It was so noisy that it gave me headaches. Driving for more than an our was extremely exhausting.
Now I had the car serviced (120K kilometres), new front tyres, old fronts to the rear, and i don't know what else they did (it's a company car, so i don't get to see the bills), and there it is again!
It runs like new! The engine is smooth, i can here it again because the deafening noises have gone, and it's that greatly appreciated driver's car again!
I'm so happy, i think i'm going to dance in the garden and sing a song for the sun!
--
Bezit en wijsheid zijn illusies
(possession and wisdom are illusions)
  Click to see the full signature.
Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Rofl, brilliant!
On our first service Alperton Ford messed up the electronics by leaving a cap open somewhere... SMART(!) Oh well we got everything sorted free ;)
-JB
Zweef® wrote:

Add pictures here
âś–
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.