00 Chevy Prizm changes power in mid drive

I have a 2000 Chevy Prizm with about 150,000 miles that has been really good to me so far with one exception. I just replaced both o2 sensors and this one problem seems to have gotten worse. In
mid-drive, or on cold morning starts, the engine likes to sputter and just about lose all power. Sometimes it sounds like it is cyclical... while holding the gas pedal even, the engine revs high, then releases, then repeats. Twice it has stalled out. Over the course of a year and a half I have replaced the Mass Air Flow Sensor and both O2 sensors now. It actually appears as though it is getting worse after replacing the O2 sensors. So maybe Im headed down the wrong track. The error codes had all pointed that way, but who knows.
Ive been thinking that it could be the catalytic converter, or perhaps something to do with the throttle. Thanks in advance for the help!
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

What were the error codes ??????
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I suggest you post this on the Toyota news group. The Corolla experts there could probably help you.
---MIKE---

>> (44 15' N - Elevation 1580')
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.