86 olds turn signal issue

car: 86 olds delta 88. 3.8L v6 154000 kms
Hi,
I've recently noticed the turn signals flickering a little faster and then some days a little slower than normal. Today when leaving from work they
don't work at all. Left or right signal. All the bulbs are good. I checked them easily because the hazard switch still work! I've checked the fuse and changed the hazard relay.
I want to know if the hazard relay and turn signal relay is the same? If not where is the turn signal relay? If it is the same, what happened?
Mark
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Generally the turn signal and hazard flasher relay are not the same. They should be under the dash on the driver's side, though I can't say exactly where they would be on this car. Probably pretty close to each other.
--
Robert Hancock Saskatoon, SK, Canada
To email, remove "nospam" from snipped-for-privacy@nospamshaw.ca
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Turn signal switch... take a look at it.. that caused my turn signals to not work unless I pulled back on the turn signal lever

then
checked
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did you check the side markers? One or more out will cause this problem. I had this happen to mine a few years back.

and
not
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.