95 safari hard cold start

ok gang! I too have the wonderful hard cold start issue that has been going on since last Jan. I have done plenty of reading on it and want some conversation!
95 safari 4.3 120,000 -no codes
Problem: When weather is under 28 degrees F , (NEVER takes more than 1/2 crank to start when 3o degrees or so. engine will take 5-6 times to start. She will catch and stall but finally on the 4th or 5th she usually stays running. Yes, I have tried to cycle the pump. My father was a GM tech so Yes, I do know what a wrench is and all of the components of this vehicle. (so feel free to speak in terms of tech talk if need be) I have read about others with the same issue and have heard everything from:
1. fuel pump -(pressure checked fine last year when this acted up (new filter within last 6 mos. (yes I can hear pump)
2. fuel pressure regulator
3. spyder injector
4. coolant temp sensor
5. plugs out of gap
6. engine temp sensor
I realize that all these things could trigger this issue. This only happens when its freezing out and will do it every time once she has sat for 8 hrs and engine goes cold. Thanks for anyone who thinks they can really identify the culprit here.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.