heat/cooling Fan speeds only run on high. 2002 Chev Malibu

Hi
My car is a 2002 Chev Malibu LS. 3.1 Litre engine. I remember someone here asking about the Fan speeds of the internal heating and cooling fan. Well, Mine just broke today. It only runs on the 2 high
settings #4 and #5. It doesnt run on 1, 2 and 3.
I think there is a web site with a schematic of a resistor block for the heating/cooling fan?
Can someone direct me to it and help me to find where the fuses might be for that Item( fan).
Thanks Larry
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The problem is the resistor pack is corroded. The resistor pack in most GM cars sticks in the duct at the output of the fan assembly. It is accessed are the passenger floorboard at the firewall. You have to be a contortionist to get to it and sometimes it is easier to take the passenger seat out to help gain access.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Replacement instructions are at: http://www.malibu02.netfirms.com/resistwalk.htm
Regards, John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Larry,
Doubt it will be the same, but worth a shot - my 2005 Colorado PU developed the same problem - wiggling the fan electrical connector made it work again. Of course, this was not a permanent fix - but pointed out the problem area (loose connector pins).
Regards,
Larry A.
wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
More likely the connection was corroded. Try paying more attention to your preventive maintenance ;)
mike

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks to everyone for the positive replies I also appreciated the web site link that will get me started. Except Mike, I didnt understand his reply. I also dont maintain the fuel filter in the gas tank either.
Thanks again
Larry

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

No one understand's Mike H.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.