Help! Electrical problems Regal

Hi folks! I'm hoping someone can help me out by pointing the way to a wire harness diagram for a 1996 Regal 4 dr (3.8 L). Here is the problem....I was told my brake lights were not working except
for the one in the rear window. I confirmed this, all else was fine. I proceeded to check the bulbs (I changed them all out last month) they were all ok. I took it to my brother's place to use his multimeter to check the connections. All the plugs appeared ok but after checking, the park, markers, running lights and dashboard lights stopped working in both front and rear. I checked the plug in the trunk and it does not appear they are getting any power. Right now, only the headlights, turn signals, emergency flashers, backing lights, and rear window brake light are working. The brake lights themselves are working intermittently. I checked the fuses but they all appear ok. The Chiltons book I have does not have good enough diagrams for me to figure this out. Any help or ideas would be greatly appreciated. Liz
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Liz wrote:

The Chiltons books aren't much good for that sort of thing. You need to get the Helm book, probably purchasable online.
---Bob Gross---
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Liz wrote: (1996 Regal 3.8 L).
Turn signals work OK. Brake lights are working intermittently. Brake lights in rear window work OK. Any help or ideas appreciated. _________________________________
Problem may be a bad turn signal switch.
Brake lights use same bulbs as turn signals. Brake pedal switch sends power to turn signal switch in steering column. Turn signal switch position decides whether to turn on brake lights or to flash them as turn signals.
Possible cheap fix: Move turn signal lever repeatedly through its full range of motion to clean corrosion on switch contacts.
Good luck.
Wendy & John. ____________________________________
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks! Thanks! Thanks! This was exactly the problem. I ended up having someone else fix it as I was afraid to mess with the steering column, but thanks to your help I went into the shop informed and saved lots of bucks. This group is a great place to find useful info. Liz

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.