check eng light

Hi all, my 2002 Sonata (4 CYL) was working fine...did something stupid...cleaned the eng compartment.
(used eng cleaner and a hose)
Ran fine for a few miles..then started to sputter at low RPM's...then
check eng light came on. Took car for a 25 mile trip to see if something got wet that might dry off...still sputtering.
It is a nice sunny 80 deg day here.
I disconnected the battery neg terminal...lifted the spark plug boots as I heard sizzling in one...full of water around the spark plug (not coolant or oil)...just water...from the hose. (guess the seal leaks on the plug wire)...got it dry...pulled the plug...looks good.
Could this have "grounded" that plug and caused the issue? 5 hours later and still doing it...so what ever I got wet is definitely dry.
Any comments on where I should look? I did not disconnect anything under the hood for the eng clean, but I did remote the large plastic tray.
This is the 2.4 4 cyl
thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

The insides of the plug boots are probably still wet. I little silicone spray may help to dry them out. Come to think of it, if the wires haven't been replaced in a while, it would be a good idea. Also, check the connections at the coil packs.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks.... I unplugged the wires for a couple hours and let it sit while I cleaned and waxed the car. May be a little moisture.
Time will tell...thanks again
Brian Nystrom wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.