XG350 Airbag Light

I have an 05 XG350L. It has been in on 5 different occasions for the airbag light coming on. The dealer says that we must be knocking it lose with stuff under the seat but we are not storing anything under the
seat. Could the movement of the seat when my wife and I switch the seat psotion be causing it to come loose?
Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Do I understand correctly that one of the connectors under the seat is actually pulling apart? They should lock together securely and shouldn't be able to come apart unless something releases the lock mechanism. Moving the seat shouldn't be able to pull it apart. If it does, there's some sort of problem that needs to be corrected, such as insufficient free length in the wire harness or an ineffective locking tab.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Harold Alterson so eloquently wrote:

Have an '04 XG350L and this issue has occurred three (3) times. First time was a bit worried and had it immediately checked at dealership. Caused by me sliding maps, cloths, etc. under my driver seat, as I've traditionally done in all my cars.
Second time, figured it was something under the seat. However, nothing was there, or had been! Brought it into dealership, fixed in 20 mins. Technician (who was great) noted that one of wires in the underseat harness had come loose.
Third time it occurred- had some groceries in the back seat well and some items (Cans, etc.) rolled under front seat- sure enough Dash indicator came on. Simply cleared under seat and pressed on harness items and top of seat; started car and indicator was off and has remained off. Next time I'm in for an oil change will have dealership check it out again.
From your incident and mine, it appears that the Airbag sensor component and/or wiring harness definitely needs some post-install "tweaks" or re-engineering.
Regards, Robert G. Ragosta
--
Linux User #273716 / Linux Machine #227435
KNode 0.7.2 / Mdk 9.2.1 / Xfce 4.2.2 / KDE 3.1.4
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.