190e 2.3 not getting fuel

Hello. Can someone please help? I parked the car 2 months ago after putting a lower control arm on it and was saving for tires, brakes and a front end
alignment. I made an appointment at the tire and alignment shop to have the work done and the car would not start. It ran fine when I parked it. I can pour fuel in the carb and start it and it will run until it burns the fuel up. I am not getting power to the fuel pumps (there are 2 of them) i checked with a test light. If I need to check anything, please be sure to tell me where the gadgets are located. I am having a hard time finding the gadgets on this car. 1993 190e automatic trans. 114000K . Please help if you can.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There's a fuel pump relay that powers the fuel pumps. That relay is probably the cause of the problem. You should know that these relays get tired and need to be replaced as they become intermittent after about 15 years use. As to where the relay is located, others here will have to tell you.
You may be able to trick it into action by charging the battery to full charge and switching the ignition ON and OFF until you hear the fuel pumps run THEN crank the motor.
--
© 2007 T.G.Lambach. Publication in any form requires prior written
permission.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.